
<!DOCTYPE html>
<html lang="en-gb" dir="ltr"
	  class='com_content view-article itemid-189 j34 mm-hover '>

<head>
<meta property="fb:pages" content="9049463449" />

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '1702696743326568');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1702696743326568&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
	  <base href="http://www.rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="keywords" content="Christian Rap news, Christian Hip Hop news, Lecrae, Thi'sl, Trip Lee, Derek Minor, Andy Mineo, Bizzle, NF, Gospel Hip Hop, Holy Hip Hop, Gospel Rap" />
  <meta name="og:title" content="Desiring God publishes powerful pro-life film with Sho Baraka, Propaganda &amp;amp; Jackie Hill Perry" />
  <meta name="og:type" content="article" />
  <meta name="og:image" content="http://rapzilla.com/rz/images/17-37-dg-hb_th.jpg" />
  <meta name="og:url" content="http://www.rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry" />
  <meta name="og:site_name" content="Rapzilla.com" />
  <meta name="og:description" content="Christian Rap / Christian Rap music, music videos, free download, new and interviews." />
  <meta name="author" content="David Daniels" />
  <meta name="description" content="Christian Rap / Christian Rap music, music videos, free download, new and interviews." />
  <meta name="generator" content="Joomla! - Open Source Content Management" />
  <title>Desiring God publishes powerful pro-life film with Sho Baraka, Propaganda &amp; Jackie Hill Perry</title>
  <link href="/rz/templates/ja_playmag/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
  <link href="http://www.rapzilla.com/rz/component/search/?Itemid=189&amp;catid=38&amp;id=14880&amp;format=opensearch" rel="search" title="Search Rapzilla.com" type="application/opensearchdescription+xml" />
  <link rel="stylesheet" href="/rz/plugins/content/authorinfobox/authorinfobox.css" type="text/css" />
  <link rel="stylesheet" href="/rz/modules/mod_raxo_related_articles/tmpl/raxo-default/raxo-default.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/system/css/system.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/local/css/themes/dark/bootstrap.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/local/css/themes/dark/template.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/local/css/themes/dark/megamenu.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/local/css/themes/dark/off-canvas.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/fonts/font-awesome/css/font-awesome.min.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/fonts/bebasneue-regular/stylesheet.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/fonts/bebasneue-thin-book/stylesheet.css" type="text/css" />
  <link rel="stylesheet" href="/rz/templates/ja_playmag/css/print.css" type="text/css" />
  <link rel="stylesheet" href="/rz/plugins/content/al_facebook_comments/assets/css/style.css" type="text/css" />
  <script src="http://connect.facebook.net/en_US/all.js#xfbml=1" type="text/javascript"></script>
  <script src="/rz/media/jui/js/jquery.min.js" type="text/javascript"></script>
  <script src="/rz/media/jui/js/jquery-noconflict.js" type="text/javascript"></script>
  <script src="/rz/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
  <script src="/rz/media/system/js/caption.js" type="text/javascript"></script>
  <script src="/rz/plugins/system/t3/base-bs3/bootstrap/js/bootstrap.js" type="text/javascript"></script>
  <script src="/rz/plugins/system/t3/base-bs3/js/jquery.tap.min.js" type="text/javascript"></script>
  <script src="/rz/plugins/system/t3/base-bs3/js/off-canvas.js" type="text/javascript"></script>
  <script src="/rz/plugins/system/t3/base-bs3/js/script.js" type="text/javascript"></script>
  <script src="/rz/plugins/system/t3/base-bs3/js/menu.js" type="text/javascript"></script>
  <script src="/rz/templates/ja_playmag/js/jquery.easing.1.3.js" type="text/javascript"></script>
  <script src="/rz/templates/ja_playmag/js/script.js" type="text/javascript"></script>
  <script src="/rz/templates/ja_playmag/js/jquery.infinitescroll.min.js" type="text/javascript"></script>
  <script src="/rz/plugins/system/t3/base-bs3/js/nav-collapse.js" type="text/javascript"></script>
  <script type="text/javascript">
jQuery(window).on('load',  function() {
				new JCaption('img.caption');
			});jQuery(document).ready(function(){
	jQuery('.hasTooltip').tooltip({"html": true,"container": "body"});
});
  </script>
  <!-- Perfect Link with Article Images on Facebook PRO -->
  <meta property="fb:app_id" content="124457807585418"/>
  <meta property="fb:admins" content="613277266"/>
  <meta property="og:title" content="Desiring God publishes powerful pro-life film with Sho Baraka, Propaganda &amp; Jackie Hill Perry"/>
  <meta property="og:type" content="article"/>
  <meta property="og:url" content="http://www.rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry"/>
  <meta property="og:site_name" content="Rapzilla.com"/>
  <meta property="og:description" content="On the eve of the anniversary of Roe v. Wade, Desiring God and Humble Beast released a film titled &quot;73-17&quot; as a plea &quot;to all who would pause to ponder the power of personhood.&quot; &quot;When we reckon with the fact that God&#039;s glory is attached to..."/>
  <meta property="og:image" content="http://rapzilla.com/rz/images/17-37-dg-hb.jpg"/>
  <style type='text/css'>
		.plg-easysharethis{ 
			padding: 0px 10px 10px 10px !important;
			margin: 10px 10px 10px 10px !important; 
			}
		</style>
  
  <meta property="og:locale" content="en_US"/>

	
<!-- META FOR IOS & HANDHELD -->
	<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no"/>
	<style type="text/stylesheet">
		@-webkit-viewport   { width: device-width; }
		@-moz-viewport      { width: device-width; }
		@-ms-viewport       { width: device-width; }
		@-o-viewport        { width: device-width; }
		@viewport           { width: device-width; }
	</style>
	<script type="text/javascript">
		//<![CDATA[
		if (navigator.userAgent.match(/IEMobile\/10\.0/)) {
			var msViewportStyle = document.createElement("style");
			msViewportStyle.appendChild(
				document.createTextNode("@-ms-viewport{width:auto!important}")
			);
			document.getElementsByTagName("head")[0].appendChild(msViewportStyle);
		}
		//]]>
	</script>
<meta name="HandheldFriendly" content="true"/>
<meta name="apple-mobile-web-app-capable" content="YES"/>
<!-- //META FOR IOS & HANDHELD -->





<link href='http://fonts.googleapis.com/css?family=Roboto:400,700,300' rel='stylesheet' type='text/css'>
<!-- Le HTML5 shim and media query for IE8 support -->
<!--[if lt IE 9]>
<script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
<script type="text/javascript" src="/rz/plugins/system/t3/base-bs3/js/respond.min.js"></script>
<![endif]-->

<!-- You can add Google Analytics here or use T3 Injection feature -->


<meta name="google-site-verification" content="Google webmaster tools verification" />

<script type="text/javascript">
 var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-1391041-1']);
_gaq.push(['_trackPageview']);

 (function() {
  var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
  ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
 })();
</script>
<!-- Google Analytics Plugin by PB Web Development -->

<script type="text/javascript">

var ados = ados || {};

ados.run = ados.run || [];

ados.run.push(function() {

/* load placement for account: FrontGate Media, site: Rapzilla.com, size: 728x90 ­ Leaderboard, zone: 728x90

ATF*/

ados_add_placement(9315, 55661, "azk31117", 4).setZone(58497);

/* load placement for account: FrontGate Media, site: Rapzilla.com, size: 300x250 ­ Medium Rectangle, zone:

300x250 ATF*/

ados_add_placement(9315, 55661, "azk33828", 5).setZone(58498);

ados_load();

});</script>


<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.defineSlot('/22663802/300x250_Rapzilla_ROS', [300, 250], 'div-gpt-ad-1365012941932-0').addService(googletag.pubads());
googletag.defineSlot('/22663802/728x90_Rapzilla_ATF_ROS', [728, 90], 'div-gpt-ad-1365012941932-1').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-1391041-1']);
  _gaq.push(['_setDomainName', 'rapzilla.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>


</head>

<body class="">
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '216202920243',
      xfbml      : true,
      version    : 'v2.4'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=124457807585418";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

<div class="t3-wrapper" > <!-- Need this wrapper for off-canvas menu. Remove if you don't use of-canvas -->

	

  
<!-- HEADER -->
<header id="t3-header" class="t3-header">
	<div class="container">
	<div class="row">

		<!-- LOGO -->
		<div class="col-xs-3 col-sm-6 col-md-6 logo">
			<div class="logo-image">
				<a href="/rz" title="Rapzilla">
											<img class="logo-img " src="/rz/images/rapzilla_logo_.png" alt="Rapzilla" />
															<span>Rapzilla</span>
				</a>
				<small class="site-slogan">Your source for Christian Hip Hop music</small>
			</div>
		</div>
		<!-- //LOGO -->
		
		<!-- RIGHT BUTTON -->
					<div class="t3-nav-btn pull-right has-collapse">
			
				<!-- OFFCANVAS -->
								<!-- //OFFCANVAS -->
				
				<!-- HEAD SEARCH -->
									<div class="dropdown nav-search pull-right ">
						<a data-toggle="dropdown" href="#" class="dropdown-toggle">
							<i class="fa fa-search"></i>									
						</a>
						<div class="nav-child dropdown-menu">
							<div class="dropdown-menu-inner">
								<div class="t3-module module " id="Mod271"><div class="module-inner"><div class="module-ct"><div class="search">
	<form action="/rz/news" method="post" class="form-inline form-search">
		<label for="mod-search-searchword" class="element-invisible">Search ...</label> <input name="searchword" id="mod-search-searchword" maxlength="200"  class="form-control" type="text" size="20" placeholder="Search ..." />		<input type="hidden" name="task" value="search" />
		<input type="hidden" name="option" value="com_search" />
		<input type="hidden" name="Itemid" value="189" />
	</form>
</div>
</div></div></div>
							</div>
						</div>
					</div>
								<!-- //HEAD SEARCH -->

				<!-- USER, FOLLOW US -->				
								<!-- //USER, FOLLOW US -->
				
			</div>
				<!-- //RIGHT BUTTON -->
		
		<!-- MAIN NAVIGATION -->
		<nav id="t3-mainnav" class="col-sm-12 col-md-7">
			<div class="navbar navbar-default t3-mainnav">
		
				<!-- Brand and toggle get grouped for better mobile display -->
				<div class="navbar-header">
				
																	<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".t3-navbar-collapse">
							<i class="fa fa-bars"></i>
						</button>
							
				</div>
		
									<div class="t3-navbar-collapse navbar-collapse collapse"></div>
						
				<div class="t3-navbar navbar-collapse collapse">
					<div  class="t3-megamenu"  data-responsive="true">
<ul class="nav navbar-nav level0">
<li  data-id="101" data-level="1">
<a class="" href="/rz/"   data-target="#">Home </a>

</li>
<li class="current active" data-id="189" data-level="1">
<a class="" href="/rz/news"   data-target="#">News </a>

</li>
<li class="dropdown mega" data-id="170" data-level="1">
<a class=" dropdown-toggle" href="/rz/music"   data-target="#" data-toggle="dropdown">Audio <b class="caret"></b></a>

<div class="nav-child dropdown-menu mega-dropdown-menu"  ><div class="mega-dropdown-inner">
<div class="row">
<div class="col-xs-12 mega-col-nav" data-width="12"><div class="mega-inner">
<ul class="mega-nav level1">
<li class="dropdown-submenu mega" data-id="134" data-level="2">
<a class="" href="/rz/music/freemp3s"   data-target="#">Free Downloads </a>

<div class="nav-child dropdown-menu mega-dropdown-menu"  ><div class="mega-dropdown-inner">
<div class="row">
<div class="col-xs-12 mega-col-nav" data-width="12"><div class="mega-inner">
<ul class="mega-nav level2">
<li  data-id="238" data-level="3">
<a class="" href="/rz/music/freemp3s/download-list"   data-target="#">Download List </a>

</li>
</ul>
</div></div>
</div>
</div></div>
</li>
<li  data-id="209" data-level="2">
<a class="" href="/rz/music/music"   data-target="#">Singles </a>

</li>
<li  data-id="234" data-level="2">
<a class="" href="/rz/music/up-next"   data-target="#">Up Next </a>

</li>
</ul>
</div></div>
</div>
</div></div>
</li>
<li  data-id="236" data-level="1">
<a class="" href="/rz/music/freemp3s"   data-target="#">Free Mp3s</a>

</li>
<li  data-id="118" data-level="1">
<a class="" href="/rz/videos"   data-target="#">Videos </a>

</li>
<li class="dropdown mega" data-id="161" data-level="1">
<a class=" dropdown-toggle" href="/rz/features"   data-target="#" data-toggle="dropdown">Features <b class="caret"></b></a>

<div class="nav-child dropdown-menu mega-dropdown-menu"  ><div class="mega-dropdown-inner">
<div class="row">
<div class="col-xs-12 mega-col-nav" data-width="12"><div class="mega-inner">
<ul class="mega-nav level1">
<li  data-id="115" data-level="2">
<a class="" href="/rz/features/releasedates"   data-target="#">Release Dates </a>

</li>
<li  data-id="117" data-level="2">
<a class="" href="/rz/features/interviews"   data-target="#">Interviews </a>

</li>
<li  data-id="177" data-level="2">
<a class="" href="/rz/features/story"   data-target="#">Columns &amp; Editorials </a>

</li>
<li  data-id="231" data-level="2">
<a class="" href="/rz/features/events"   data-target="#">Events </a>

</li>
<li  data-id="224" data-level="2">
<a class="" href="/rz/features/reviews"   data-target="#">Reviews </a>

</li>
<li  data-id="222" data-level="2">
<a class="" href="/rz/features/listening-session"   data-target="#">Listening Session </a>

</li>
<li  data-id="244" data-level="2">
<a class="" href="/rz/features/remixcontest"   data-target="#">Remix Contests </a>

</li>
</ul>
</div></div>
</div>
</div></div>
</li>
<li  data-id="284" data-level="1">
<a class="" href="/rz/contact"   data-target="#">Contact </a>

</li>
<li  data-id="285" data-level="1">
<a class="" href="/rz/advertise"   data-target="#">Advertise </a>

</li>
</ul>
</div>

				</div>
		
			</div>
		</nav>
		<!-- //MAIN NAVIGATION -->
	</div>
	</div>
</header>
<!-- //HEADER -->

  
	<!-- TOP BANNER -->
	<div class="wrap t3-topbanner text-center ">
		<div class="container">
			

<div class="custom"  >
	<table align=center><tr><td>
<a href="http://bit.ly/2fgcV1k" target="_blank"><img src="http://rapzilla.com/20-off-Blacksheep-Banner-_banner_1235.gif" style='width:100%;' border="0"></a></td><td></td></tr></table>

<!-- style='width:56%;' border="0" -->
<!-- <table><tr><td>
<a href="http://rapzil.la/1qHpiB3" target="_blank"><img src="http://rapzilla.com/rz/images/Bizzle_Rapzilla_1235x300.jpg" style='width:100%;' border="0"></a></td></tr></table>
 --></div>

		</div>
	</div>
	<!-- //TOP BANNER -->
  
  
  
  


  
<div id="t3-mainbody" class="container t3-mainbody one-sidebar-right">
	<div class="row">

		<!-- MAIN CONTENT -->
		<div id="t3-content" class="t3-content col-xs-12 col-sm-12  col-md-9">
			<!-- MAST TOP 1-->
						<div class="t3-mast-top-1 ">
				

<div class="custom"  >
	<!-- 728x90_Rapzilla_ATF_ROS -->
<div id='div-gpt-ad-1365012941932-1' style='width:728px; height:90px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1365012941932-1'); });
</script>
</div><!--  <a href="http://bit.ly/1w5Bekp" target=_blank><img src="http://rapzilla.com/rz/images/banners/flavorfest_90.jpg" border=0</img></a> --><br></div>

			</div>
						<!-- //MAST TOP 1-->
		
			<!-- CONTENT MAST TOP -->
						<!-- //CONTENT MAST TOP -->
						

	<div class="page-header clearfix">
		<h1 class="page-title">Christian Rap News | Christian Hip Hop News</h1>
	</div>

<div class="item-page clearfix">


<!-- Article -->
<article itemscope itemtype="http://schema.org/Article">
	<meta itemprop="inLanguage" content="en-GB" />
	
<header class="article-header">
	<h1 class="article-title" itemprop="name">
					<a href="/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry" itemprop="url" title="Desiring God publishes powerful pro-life film with Sho Baraka, Propaganda &amp; Jackie Hill Perry">
				Desiring God publishes powerful pro-life film with Sho Baraka, Propaganda &amp; Jackie Hill Perry</a>
			</h1>

			</header>
<!-- Aside -->
<aside class="article-aside clearfix">
    	<dl class="article-info  muted">

		
			<dt class="article-info-term">
													Details							</dt>

							
<dd class="createdby hasTooltip" itemprop="author" itemscope itemtype="http://schema.org/Person" title="Written by ">
	<i class="fa fa-user"></i>
			<span itemprop="name">David Daniels</span>	</dd>
			
			
					
												<dd class="create">
					<i class="fa fa-calendar"></i>
					<time datetime="2017-01-23T04:32:50+00:00" itemprop="dateCreated">
						Created: 23 January 2017					</time>
			</dd>			
			
						</dl>
    
    
  </aside>  
<!-- //Aside -->



	

	
	<div class="pull-left item-image article-image article-image-full">
		<img src="/rz/images/17-37-dg-hb.jpg"
			alt="" itemprop="image"/>
	</div>


		
	<div class="row">
				<div class="col-lg-12 col-sm-12 col-xs-12 addthis-wrap">
			<div align='left'><script type='text/javascript' src='https://ws.sharethis.com/button/buttons.js'></script><script type='text/javascript'>stLight.options({nativeCount:true,doNotHash : true, doNotCopy: true ,hashAddressBar: false,shorten: 'false'}); ;  </script><div class='plg-easysharethis'><span  st_url='http://rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry' class='st_twitter_hcount' st_via='' st_title='Desiring God publishes powerful pro-life film with Sho Baraka, Propaganda & Jackie Hill Perry'></span><span st_url='http://rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry' class='st_facebook_hcount' ></span><span st_url='http://rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry' class='st_googleplus_hcount' ></span></div></div>		</div>
				<section class="col-lg-12 col-sm-12 col-xs-12 article-content clearfix" itemprop="articleBody">


						
			On the eve of the anniversary of Roe v. Wade, <a href="http://www.desiringgod.org/person" target=_blank>Desiring God</a> and Humble Beast released a film titled "73-17" as a plea "to all who would pause to ponder the power of personhood." <br><br>

"When we reckon with the fact that God's glory is attached to personhood, it changes your whole paradigm on how you see babies, how you see infants, and thus, how you see abortion, where it's like ... it's not a petty thing," Humble Beast artist <a href="http://www.desiringgod.org/73-17-in-the-making" target=_blank>Jackie Hill Perry said</a>. "This is glory. God's glory is on this person because they are made in his image."<br><br>

The film features Hill Perry, Sho Baraka and Propaganda, and not only addresses abortion, but also the "plight of countless black women who, next to the children, have been the greatest victims of this system."<br><br>

"What we wanted to do was not only with the writing, but visually really catch the nuances and the complexity of what a comprehensive, pro-life position would be," Propaganda said.<br><br>

Watch "73-17" and its behind-the-scenes video, which explains the concept of the production, below.<br><br>

"Humble Beast does nothing without really thinking through how to not only bring theological excellence, but aesthetic excellence as well," Sho Baraka said, "and so this video and this project I think has a very subtle but powerful statement from the car. Where are we going? Why are we in a car? Where is this car taking us?"<br><br>

<iframe src="https://player.vimeo.com/video/200063742" width="100%" height="490" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>

<iframe src="https://player.vimeo.com/video/200398710" width="100%" height="490" frameborder="0" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe><!-- Author Info Box Plugin for Joomla! - Kubik-Rubik Joomla! Extensions - Viktor Vogel --><div id="author_infobox"><div class="author_infobox_title">About the Author</div><div class="author_infobox_image_authorlist"><img src="/rz/images/socialmedia/daviddaniels.jpg" alt="" /></div><div class="author_infobox_description">David Daniels is a reporter at Rapzilla.com. He has been published at The Washington Times, Bleacher Report, Christianity Today, HipHopDX, The Gospel Coalition, The Daily Caller, Global Grind and Sphere of Hip Hop.<br /><a href="https://www.facebook.com/david.daniels.359" target="_blank"><img src="http://rapzilla.com/rz/images/socialmedia/fb.png" width="30 height=30 border=0/" /></a><a href="https://twitter.com/daviddaniels" target="_blank"><img src="http://rapzilla.com/rz/images/socialmedia/twitter.png" width="30 height=30 border=0/" /></a> </div></div><br class="clear" /><div class="al_buttons_container"><div class="al_like al_btn"><fb:like href="http://www.rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry" layout="button_count" show_faces="false" send="true" width="150" colorscheme="light"></fb:like> 
</div></div><div id="fb-root"></div><script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) return;
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=216202920243";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script><div class="al_comments_container"><div class="al_comments_box"><fb:comments href="http://www.rapzilla.com/rz/news/38-backstage/14880-desiring-god-publishes-powerful-pro-life-film-with-sho-baraka-propaganda-jackie-hill-perry" num_posts="20" width="100%" colorscheme="light"></fb:comments></div><div  id="al_link20" style="display:none;"><a href="http://www.alexlopezit.com/facebook-comments-plugin-for-joomla" title="Facebook Social Comments"><strong>Facebook Social Comments</strong></a></div></div>		</section>
	</div>

  <!-- footer -->
    <!-- //footer -->

	
	
	
</article>
<!-- //Article -->


<div class="raxo-after-content">		<div class="moduletable">
							<h3>Related Articles</h3>
						
<div class="raxo-related-articles raxo-default">



<div class="raxo-itemsbox">

		<div class="raxo-item raxo-category-id16">

				<div class="raxo-img"><a href="/rz/videos/14621-video-sho-baraka-my-hood-usa-1937"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2Fsho-baraka-my-hood-usa_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Video: Sho Baraka - My Hood, USA, 1937" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/videos/14621-video-sho-baraka-my-hood-usa-1937">Video: Sho Baraka - My Hood, USA, 1937</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">Music Videos</span>
			
			
		</div>
		
				<div class="raxo-text">Humble Beast Records released a music video on Wednesday for Sho Baraka's song "My Hood, USA, 1937", which is track No. 11 of his Oct. album The Narrative.
			
		</div>
		
	</div>
		<div class="raxo-item raxo-category-id38">

				<div class="raxo-img"><a href="/rz/news/38-backstage/14539-watch-sho-baraka-and-propaganda-s-spotlight-tour-conversation"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2Fspotlight-sho-baraka-propaganda_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Watch Sho Baraka and Propaganda's Spotlight Tour conversation" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/news/38-backstage/14539-watch-sho-baraka-and-propaganda-s-spotlight-tour-conversation">Watch Sho Baraka and Propaganda's Spotlight Tour conversation</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">News</span>
			
			
		</div>
		
				<div class="raxo-text">Humble Beast Records released a video this weekend of Sho Baraka and Propaganda's Spotlight Tour, where "compassion, unity, ethics, race, faith and the church" were discussed.
			
		</div>
		
	</div>
		<div class="raxo-item raxo-category-id38">

				<div class="raxo-img"><a href="/rz/news/38-backstage/14501-sho-baraka-on-rapzilla-com-live-with-chris-chicago-ep-42"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2Frapzilla-live-sho-baraka_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Sho Baraka on Rapzilla.com LIVE with Chris Chicago - Ep. 42" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/news/38-backstage/14501-sho-baraka-on-rapzilla-com-live-with-chris-chicago-ep-42">Sho Baraka on Rapzilla.com LIVE with Chris Chicago - Ep. 42</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">News</span>
			
			
		</div>
		
				<div class="raxo-text">Sho Baraka talks to us about his brand new album The Narrative, race relations, social injustice, what white brothers and sisters can do to help and more in the featured interview on our 42nd episode&hellip;
			
		</div>
		
	</div>
		<div class="raxo-item raxo-category-id38">

				<div class="raxo-img"><a href="/rz/news/38-backstage/14403-sho-baraka-s-the-narrative-and-bizzle-s-crowns-crosses-share-several-billboard-charts"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2Fsho-biz_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Sho Baraka's 'The Narrative' and Bizzle's 'Crowns &amp; Crosses' share several Billboard charts" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/news/38-backstage/14403-sho-baraka-s-the-narrative-and-bizzle-s-crowns-crosses-share-several-billboard-charts">Sho Baraka's 'The Narrative' and Bizzle's 'Crowns & Crosses' share several Billboard charts</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">News</span>
			
			
		</div>
		
				<div class="raxo-text">Billboard announced its charts for the week of Nov. 12 on Tuesday, and Sho Baraka's new album The Narrative and Bizzle's Crowns & Crosses both made multiple first-week appearances.
			
		</div>
		
	</div>
	
</div>


</div>
		</div>
			<div class="moduletable">
							<h3>Trending </h3>
						
<div class="raxo-related-articles raxo-default">



<div class="raxo-itemsbox">

		<div class="raxo-item raxo-category-id21">

				<div class="raxo-img"><a href="/rz/features/14705-christian-hip-hop-s-best-of-2016-nominees"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2Fbest-of-2016_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Christian Hip Hop's Best of 2016 Nominees" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/features/14705-christian-hip-hop-s-best-of-2016-nominees">Christian Hip Hop's Best of 2016 Nominees</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">Story</span>
			
			
		</div>
		
				<div class="raxo-text">#article-index, .article-index { margin-left: 2%; } .article-image-full.item-image { max-width: 73%; } As 2016 comes to a close, Rapzilla.com will celebrate Christian hip hop's best art and artists&hellip;
			
		</div>
		
	</div>
		<div class="raxo-item raxo-category-id21">

				<div class="raxo-img"><a href="/rz/features/14785-rapzilla-com-s-15-freshman-of-2017"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2FRapzilla-Freshman-2017_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Rapzilla.com’s 15 Freshman of 2017" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/features/14785-rapzilla-com-s-15-freshman-of-2017">Rapzilla.com’s 15 Freshman of 2017</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">Story</span>
			
			
		</div>
		
				<div class="raxo-text">Rapzilla.com is pleased to announce its seventh annual Freshmen class, which is made up of the most promising up-and-comers in Christian hip hop.
			
		</div>
		
	</div>
		<div class="raxo-item raxo-category-id38">

				<div class="raxo-img"><a href="/rz/news/38-backstage/14665-lecrae-creates-theme-song-for-espn-s-sportscenter"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2Fcoasttocoast_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Lecrae creates theme song for ESPN's SportsCenter" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/news/38-backstage/14665-lecrae-creates-theme-song-for-espn-s-sportscenter">Lecrae creates theme song for ESPN's SportsCenter</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">News</span>
			
			
		</div>
		
				<div class="raxo-text">ESPN gave Lecrae a high profile feature as they enlisted him to do the intro song for SportsCenter’s Coast-to-Coast show.
			
		</div>
		
	</div>
		<div class="raxo-item raxo-category-id38">

				<div class="raxo-img"><a href="/rz/news/38-backstage/14735-lecrae-to-release-new-album-in-early-2017"><img src="/rz/modules/mod_raxo_related_articles/tools/tb.php?src=%2Frz%2Fimages%2Flecrae_2017_th.jpg&amp;w=240&amp;h=160&amp;zc=1" width="240" height="160" title="Lecrae to Release New Album in 'Early 2017'" alt="" /></a></div>
		
		
				<h4 class="raxo-title"><a href="/rz/news/38-backstage/14735-lecrae-to-release-new-album-in-early-2017">Lecrae to Release New Album in 'Early 2017'</a></h4>
		
				<div class="raxo-info">

						in <span class="raxo-category">News</span>
			
			
		</div>
		
				<div class="raxo-text">After a strong 2016, Lecrae is heading into 2017 with new music, and a focus as solid as ever.
			
		</div>
		
	</div>
	
</div>


</div>
		</div>
	</div></div>
		</div>
		<!-- //MAIN CONTENT -->

		<!-- SIDEBAR RIGHT -->
		<div class="t3-sidebar t3-sidebar-right col-xs-12 col-sm-4  col-md-3 ">
			<div class="t3-module module " id="Mod228"><div class="module-inner"><div class="module-ct">

<div class="custom"  >
	<!-- 300x250_Rapzilla_ROS -->
<div id='div-gpt-ad-1365012941932-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1365012941932-0'); });
</script>
</div></div>
</div></div></div><div class="t3-module module " id="Mod289"><div class="module-inner"><h3 class="module-title "><span>Our Playlist</span></h3><div class="module-ct">

<div class="custom"  >
	<iframe src="//playlists.applemusic.com/embed/pl.6c8cb6a58af24dfb8d0defb7624dcfbd?country=us&app=music" height="400px" width="100%" frameborder="0"></iframe>
</div>
</div></div></div><div class="t3-module module-style3 " id="Mod102"><div class="module-inner"><h3 class="module-title "><span>SPOTLIGHT VIDEO</span></h3><div class="module-ct">

<div class="custom-style3"  >
	<iframe width="100%" height="230" src="https://www.youtube.com/embed/videoseries?list=PLty0sdOfsW2TTN68FZ4NNr0QR0dsa9WEi" frameborder="0" allowfullscreen></iframe></div>
</div></div></div><div class="t3-module modulehighlight-module " id="Mod156"><div class="module-inner"><h3 class="module-title "><span>FEATURED FREE DOWNLOAD</span></h3><div class="module-ct">

<div class="customhighlight-module"  >
	<iframe width="100%" height="350" scrolling="no" frameborder="no" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/302569013&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false&amp;visual=true"></iframe>

<center><a href="http://rapzilla.com/rz/music/freemp3s/14838-t-prophet-transparency"><img src="http://www.rapzilla.com/rz/images/stories/download-buttons01.png"/></a></center></div>
</div></div></div><div class="t3-module module " id="Mod272"><div class="module-inner"><h3 class="module-title "><span>Popular Tags</span></h3><div class="module-ct"><div class="tagspopular">
	<ul>
		<li>		<a href="/rz/component/tags/tag/213-skrip">
			Skrip</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/1804-social-club-misfits">
			Social Club Misfits</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/1675-rapzilla-com-live-with-chris-chicago">
			Rapzilla.com Live with Chris Chicago</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/265-kj-52">
			KJ-52</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/110-young-noah">
			Young Noah</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/126-christon-gray">
			Christon Gray</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/485-aaron-cole">
			Aaron Cole</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/469-mission">
			Mission</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/377-angie-rose">
			Angie Rose</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/6-lecrae">
			Lecrae</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/1656-rapzilla-com-live">
			Rapzilla.com Live</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/405-loso">
			Loso</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/1894-sean-david-grant">
			Sean David Grant</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/161-julien">
			Julien</a>
			</li>
		<li>		<a href="/rz/component/tags/tag/120-andy-mineo">
			Andy Mineo</a>
			</li>
		</ul>
</div>
</div></div></div><div class="t3-module module " id="Mod284"><div class="module-inner"><div class="module-ct">

<div class="custom"  >
	<!-- 300x250_Rapzilla_ROS -->
<div id='div-gpt-ad-1365012941932-0' style='width:300px; height:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1365012941932-0'); });
</script>
</div></div>
</div></div></div>
		</div>
		<!-- //SIDEBAR RIGHT -->

	</div>
</div> 


  
  
  

  

  
<!-- FOOTER -->
<footer id="t3-footer" class="wrap t3-footer">

	
	<section class="t3-copyright">
		<div class="container">
			<div class="row">
				<div class="col-md-12 copyright ">
					
				</div>
							</div>
		</div>
	</section>

</footer>
<!-- //FOOTER -->
</div>

</body>

</html>